Epicor Data Analytics - Performance Degradation – Investigation in Progress – Incident details

All systems operational

Performance Degradation – Investigation in Progress

Resolved
Degraded performance
Started 3 months agoLasted about 2 hours

Affected

North America

Degraded performance from 4:06 PM to 5:45 PM, Operational from 5:45 PM to 6:04 PM

Epicor Data Analytics (EDA) - US

Degraded performance from 4:06 PM to 5:45 PM, Operational from 5:45 PM to 6:04 PM

EDA Budgets & Forecasts - US

Degraded performance from 4:06 PM to 5:45 PM, Operational from 5:45 PM to 6:04 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We've implemented a fix and are actively monitoring system performance. Service has stabilized, and we’ll continue to observe to ensure full resolution.

  • Investigating
    Investigating

    We're currently investigating a system issue that may be affecting performance or availability for some customers. Our team is actively working to identify the root cause and will share updates as more information becomes available. We appreciate your patience and understanding.